The previously reported incident has been resolved. All affected services are available and operating normally.
Since the restoration of services, no further issues have been identified. Our technical team has continued to monitor the systems closely and confirms that all services remain stable.
We appreciate your patience and understanding during this disruption.
Posted Jun 19, 2026 - 19:48 CEST
Monitoring
The previously reported incident has been resolved. All affected services are currently available and operating normally.
Our technical team will continue to monitor the situation closely to ensure ongoing stability and to identify any potential follow-up issues.
We appreciate your patience and understanding during this disruption.
Posted Jun 18, 2026 - 19:42 CEST
Investigating
We are currently experiencing a major outage affecting our website and mail services.
As a result, websites, customer portals, and email communication may be unavailable or experience interruptions.
Our technical team is already aware of the issue and is actively working to restore all affected services as quickly as possible.
We will provide updates as soon as more information becomes available.
Posted Jun 18, 2026 - 19:20 CEST
This incident affected: internal systems (website) and products (webhost 1).